summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-28 13:46:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-28 17:28:20 +0000
commit0070b508259bb187a369a522f2884921b0c4e2fa (patch)
treea157a421c45ee4a7af545a3233075faf43c97e9e /meta/recipes-graphics
parent35983262caca0f1fa0d2f6b429152c8d5cdf1be6 (diff)
downloadopenembedded-core-contrib-0070b508259bb187a369a522f2884921b0c4e2fa.tar.gz
libepoxy: enable native/nativesdk variants
libepoxy is a requirement of virglrenderer. Note that we strip RPATH from the library, as this allows fall-through to the host GL implementation, instead of attempting (and failing) to use mesa-native. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb b/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
index 92f644c039..dd706a9606 100644
--- a/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
+++ b/meta/recipes-graphics/libepoxy/libepoxy_1.5.3.bb
@@ -14,9 +14,25 @@ UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases"
inherit meson pkgconfig distro_features_check
REQUIRED_DISTRO_FEATURES = "opengl"
+REQUIRED_DISTRO_FEATURES_class-native = ""
+REQUIRED_DISTRO_FEATURES_class-nativesdk = ""
PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl"
PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no, virtual/libx11 virtual/libgl"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl"
EXTRA_OEMESON += "-Dtests=false"
+
+PACKAGECONFIG_class-native = "egl"
+PACKAGECONFIG_class-nativesdk = "egl"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# This will ensure that dlopen will attempt only GL libraries provided by host
+do_install_append_class-native() {
+ chrpath --delete ${D}${libdir}/*.so
+}
+
+do_install_append_class-nativesdk() {
+ chrpath --delete ${D}${libdir}/*.so
+}