aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2013-07-11 01:05:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-13 18:23:32 +0100
commitf8bee41377ccf9b4f614c687185d73c9e1286e22 (patch)
tree696c4de808f5285aebb67608ba231b00f41b6d94 /meta/recipes-graphics/xorg-xserver
parent5d17796c2440f691da28afe0e2e27a0f7bf8bf12 (diff)
downloadopenembedded-core-contrib-f8bee41377ccf9b4f614c687185d73c9e1286e22.tar.gz
xserver-xorg: extend packageconfig and dependencies
- split glx into dri, dri2 and glx, to be able to select e.g. dri2 only - update dependencies to match configure.ac (From OE-Core rev: 408766da9cc1f2ca80d0b3f13575fea8f33cab3e) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-xserver')
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg.inc10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
index 3d68413dfa..ab8171cc4b 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
@@ -23,7 +23,7 @@ S = "${WORKDIR}/${XORG_PN}-${PV}"
inherit autotools pkgconfig
-PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86vidmodeproto compositeproto recordproto resourceproto videoproto scrnsaverproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto"
+PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86vidmodeproto compositeproto recordproto resourceproto videoproto scrnsaverproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto"
LIB_DEPS = "pixman libxfont xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess openssl libgcrypt"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} font-util"
@@ -122,11 +122,11 @@ EXTRA_OECONF += "--with-fop=no \
ac_cv_file__usr_share_sgml_X11_defs_ent=no \
"
-PACKAGECONFIG ??= "udev ${@base_contains('DISTRO_FEATURES', 'opengl', 'glx', '', d)}"
+PACKAGECONFIG ??= "udev ${@base_contains('DISTRO_FEATURES', 'opengl', 'dri dri2 glx', '', d)}"
PACKAGECONFIG[udev] = "--enable-config-udev,--disable-config-udev,udev"
-PACKAGECONFIG[glx] = "--enable-dri --enable-dri2 --enable-glx --enable-glx-tls,\
- --disable-dri --disable-dri2 --disable-glx,\
- xf86driproto dri2proto mesa"
+PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,glproto mesa xf86driproto"
+PACKAGECONFIG[dri2] = "--enable-dri2,--disable-dri2,dri2proto"
+PACKAGECONFIG[glx] = "--enable-glx --enable-glx-tls,--disable-glx,glproto virtual/libgl virtual/libx11"
do_install_append () {
# Its assumed base-files creates this for us