aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-xserver
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-02-05 14:00:40 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-22 06:09:22 -0800
commit4f977ab120d8e8cb2601e42f200a76eefd169ef4 (patch)
tree8cf51527f6bc4bf43901a14e16fa8c3cca5d8e2b /meta/recipes-graphics/xorg-xserver
parentf017eb38bbca4af106ed359adfbbd4bfdf9bad5c (diff)
downloadopenembedded-core-contrib-4f977ab120d8e8cb2601e42f200a76eefd169ef4.tar.gz
xserver-xf86-config: don't ship empty xorg.conf
Many hardware platforms can autodetect their hardware and don't need a xorg.conf at all. Make it easy for BSPs to not ship a xorg.conf by not installing empty xorg.conf files. (From OE-Core rev: 4b46149df5f123c7acf4699dbc552cc0e07f709a) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-xserver')
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
index 3c29f8b7bf..90d6f56746 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bb
@@ -7,12 +7,14 @@ PR = "r11"
SRC_URI = "file://xorg.conf"
-CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+CONFFILES_${PN} = "${sysconfdir}/X11/xorg.conf"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+ALLOW_EMPTY_${PN} = "1"
do_install () {
- install -d ${D}/${sysconfdir}/X11
- install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+ if test -s ${WORKDIR}/xorg.conf; then
+ install -d ${D}/${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+ fi
}
-