summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-proto
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2020-10-30 14:45:51 +0100
committerSteve Sakoman <steve@sakoman.com>2020-11-02 04:15:11 -1000
commit0f688c1419b1e2dfddff3c985f89a3f1949fc9fb (patch)
tree16ad9201e5f68eec8a15a7690ba9e8af49843790 /meta/recipes-graphics/xorg-proto
parent5f644082fc3c2bbd89b898d5ca7cd4414cda4a64 (diff)
downloadopenembedded-core-contrib-0f688c1419b1e2dfddff3c985f89a3f1949fc9fb.tar.gz
xcb-proto: backport fix for python gcd function
This backports the fix [1] for the following build error for nativesdk on Fedora 33 which is caused by the removal of fractions.gcd() in favor of math.gcd() in python 3.9 [2]: ImportError: cannot import name 'gcd' from 'fractions' (/usr/lib64/python3.9/fractions.py) [1] https://gitlab.freedesktop.org/xorg/proto/xcbproto/-/commit/426ae35bee1fa0fdb8b5120b1dcd20cee6e34512 [2] https://bugs.python.org/issue39350 Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-proto')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto/0001-xcbgen-use-math-gcd-for-python-3-5.patch40
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb3
2 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto/0001-xcbgen-use-math-gcd-for-python-3-5.patch b/meta/recipes-graphics/xorg-proto/xcb-proto/0001-xcbgen-use-math-gcd-for-python-3-5.patch
new file mode 100644
index 0000000000..f9f4424da5
--- /dev/null
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto/0001-xcbgen-use-math-gcd-for-python-3-5.patch
@@ -0,0 +1,40 @@
+From 426ae35bee1fa0fdb8b5120b1dcd20cee6e34512 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
+Date: Mon, 1 Jun 2020 12:24:16 +0200
+Subject: [PATCH] xcbgen: Use math.gcd() for Python >= 3.5.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+fractions.gcd() has been deprecated since Python 3.5, and
+was finally dropped in Python 3.9. It is recommended to
+use math.gcd() instead.
+
+Signed-off-by: Björn Esser <besser82@fedoraproject.org>
+Upstream-Status: Backport [https://gitlab.freedesktop.org/xorg/proto/xcbproto/-/commit/426ae35bee1fa0fdb8b5120b1dcd20cee6e34512]
+Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
+---
+ xcbgen/align.py | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/xcbgen/align.py b/xcbgen/align.py
+index d4c12ee..5c4f517 100644
+--- a/xcbgen/align.py
++++ b/xcbgen/align.py
+@@ -2,7 +2,12 @@
+ This module contains helper classes for alignment arithmetic and checks
+ '''
+
+-from fractions import gcd
++from sys import version_info
++
++if version_info[:2] >= (3, 5):
++ from math import gcd
++else:
++ from fractions import gcd
+
+ class Alignment(object):
+
+--
+GitLab
+
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
index 7467090920..1f41821302 100644
--- a/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
@@ -11,7 +11,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7 \
file://src/dri2.xml;beginline=2;endline=28;md5=f8763b13ff432e8597e0d610cf598e65"
-SRC_URI = "http://xcb.freedesktop.org/dist/${BP}.tar.bz2"
+SRC_URI = "http://xcb.freedesktop.org/dist/${BP}.tar.bz2 \
+ file://0001-xcbgen-use-math-gcd-for-python-3-5.patch"
SRC_URI[md5sum] = "abe9aa4886138150bbc04ae4f29b90e3"
SRC_URI[sha256sum] = "7b98721e669be80284e9bbfeab02d2d0d54cd11172b72271e47a2fe875e2bde1"