summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2021-03-10 13:54:20 +0100
committerAnuj Mittal <anuj.mittal@intel.com>2021-03-22 09:36:33 +0800
commitb4620992fb5d81ca0bab3979297aa78fe00da85f (patch)
tree44d5a5de855a3faf203fd03ad15846cd69bdc759 /meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb
parent50b7bd03fad8564205dd870c4dd120a62541767a (diff)
downloadopenembedded-core-contrib-b4620992fb5d81ca0bab3979297aa78fe00da85f.tar.gz
xcb-proto: update to 1.14.1
This fixes [1] the following build error for nativesdk on Fedora 33 which is caused by the removal of fractions.gcd() in favor of math.gcd() in python 3.9 [2]: ImportError: cannot import name 'gcd' from 'fractions' (/usr/lib64/python3.9/fractions.py) Furthermore the SRC_URI is adapted as the old one doesn't provide the 1.14.1 archive. [1] https://gitlab.freedesktop.org/xorg/proto/xcbproto/-/commit/426ae35bee1fa0fdb8b5120b1dcd20cee6e34512 [2] https://bugs.python.org/issue39350 It's needed in gatesgarth and possibly dunfell as well to support distributions with python-3.9 as we build libxcb-native, which is failing with xcb-proto-1.14. 1.14.1 is a bug fix release: https://lists.x.org/archives/xorg-announce/2020-October/003061.html Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb
new file mode 100644
index 0000000000..52e474a2e9
--- /dev/null
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.14.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "XCB: The X protocol C binding headers"
+DESCRIPTION = "Function prototypes for the X protocol C-language Binding \
+(XCB). XCB is a replacement for Xlib featuring a small footprint, \
+latency hiding, direct access to the protocol, improved threading \
+support, and extensibility."
+HOMEPAGE = "http://xcb.freedesktop.org"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
+
+SECTION = "x11/libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7 \
+ file://src/dri2.xml;beginline=2;endline=28;md5=f8763b13ff432e8597e0d610cf598e65"
+
+SRC_URI = "https://xorg.freedesktop.org/archive/individual/proto/${BP}.tar.xz"
+SRC_URI[sha256sum] = "f04add9a972ac334ea11d9d7eb4fc7f8883835da3e4859c9afa971efdf57fcc3"
+
+inherit autotools pkgconfig python3native
+
+PACKAGES += "python-xcbgen"
+
+FILES_${PN} = ""
+FILES_${PN}-dev += "${datadir}/xcb/*.xml ${datadir}/xcb/*.xsd"
+FILES_python-xcbgen = "${PYTHON_SITEPACKAGES_DIR}"
+
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
+
+BBCLASSEXTEND = "native nativesdk"