aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb.inc
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-09 16:58:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-10 11:28:15 +0000
commite7876641c684448c6760050f23fd17dd5e850b48 (patch)
tree36456919cc431d39cb3e0855de99a521d24c52b1 /meta/recipes-graphics/xorg-lib/libxcb.inc
parent380d48da4b476f43554e38e464e7e25c930f88b6 (diff)
downloadopenembedded-core-contrib-e7876641c684448c6760050f23fd17dd5e850b48.tar.gz
libxcb: fix rebuild when MACHINE changes
This recipe was patching the sysroot path directly into configure.ac, which fails when the same source tree is re-used for another machine. Instead, patch in $PKG_CONFIG_SYSROOT_DIR which is already exported for use by pkg-config. Also remove some commented-out lines that have no purpose. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb.inc')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb.inc16
1 files changed, 2 insertions, 14 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb.inc b/meta/recipes-graphics/xorg-lib/libxcb.inc
index 91df1be8c5..7f9b0af66c 100644
--- a/meta/recipes-graphics/xorg-lib/libxcb.inc
+++ b/meta/recipes-graphics/xorg-lib/libxcb.inc
@@ -12,10 +12,9 @@ LICENSE = "MIT-X"
PARALLEL_MAKE = ""
DEPENDS = "xcb-proto xproto libxau libxslt-native xcb-proto-native libpthread-stubs"
-# DEPENDS += "xsltproc-native gperf-native"
-SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2"
-# file://xcbincludedir.patch"
+SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
+ file://xcbincludedir.patch"
PACKAGES =+ "libxcb-composite libxcb-damage libxcb-dpms libxcb-glx \
libxcb-randr libxcb-record libxcb-render libxcb-res \
@@ -25,7 +24,6 @@ PACKAGES =+ "libxcb-composite libxcb-damage libxcb-dpms libxcb-glx \
libxcb-dri2 libxcb-dri3 libxcb-present"
FILES_${PN} = "${libdir}/libxcb.so.*"
-#FILES_${PN}-dev = "${libdir}/libxcb.* ${libdir}/pkgconfig/*.pc ${includedir}/xcb/*.h"
FILES_libxcb-dri2 = "${libdir}/libxcb-dri2.so.*"
FILES_libxcb-dri3 = "${libdir}/libxcb-dri3.so.*"
FILES_libxcb-composite = "${libdir}/libxcb-composite.so.*"
@@ -52,13 +50,3 @@ FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
FILES_libxcb-present = "${libdir}/libxcb-present.so.*"
inherit autotools pkgconfig pythonnative
-
-# XCBPROTO_XCBINCLUDEDIR is set based on `pkg-config --variable=xcbincludedir xcb-proto`
-# but the xcbincludedir variable doesn't point into the staging area, so it needs some
-# tweaking here:
-do_configure_prepend () {
- sed -i "s|XCBPROTO_XCBINCLUDEDIR=\`|XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR_HOST}/\`|" \
- ${S}/configure.ac
- sed -i "s|XCBPROTO_XCBPYTHONDIR=\`|XCBPROTO_XCBPYTHONDIR=${STAGING_DIR_HOST}/\`|" \
- ${S}/configure.ac
-}