summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-10-04 22:43:40 +0100
committerSteve Sakoman <steve@sakoman.com>2023-10-19 04:34:38 -1000
commit79f9c062df37ca15649d41bb6501e6fab2d73114 (patch)
treed60ec083337b8a3e226649b72da388cf2b9ddd17 /meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb
parent7466db00ca2f884cf58504c3910b858a87f33128 (diff)
downloadopenembedded-core-contrib-79f9c062df37ca15649d41bb6501e6fab2d73114.tar.gz
libx11: upgrade to 1.8.7
This incorporates fixes for the following CVEs: - CVE-2023-43785 - CVE-2023-43786 - CVE-2023-43787 Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit a1534bb34b680bfc5cb2f35b5fd5a0c2afed6368) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb b/meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb
new file mode 100644
index 0000000000..5f14e62446
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.8.7.bb
@@ -0,0 +1,43 @@
+SUMMARY = "Xlib: C Language X Interface library"
+
+DESCRIPTION = "This package provides a client interface to the X Window \
+System, otherwise known as 'Xlib'. It provides a complete API for the \
+basic functions of the window system."
+
+require xorg-lib-common.inc
+
+LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116"
+
+DEPENDS += "xorgproto \
+ xtrans \
+ libxcb \
+ xorgproto-native \
+ autoconf-archive-native \
+ "
+
+PROVIDES = "virtual/libx11"
+
+PE = "1"
+
+XORG_PN = "libX11"
+
+SRC_URI += "file://disable_tests.patch"
+
+SRC_URI[sha256sum] = "05f267468e3c851ae2b5c830bcf74251a90f63f04dd7c709ca94dc155b7e99ee"
+
+inherit gettext
+
+EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
+EXTRA_OEMAKE += 'CWARNFLAGS=""'
+
+PACKAGECONFIG ??= "xcms"
+PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
+
+PACKAGES =+ "${PN}-xcb"
+
+FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
+FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*"
+FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
+
+BBCLASSEXTEND = "native nativesdk"