summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-12-29 21:11:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-31 17:06:19 +0000
commite13f651f73db0f26f4645447ab5fa17e36d1903b (patch)
treeb5bfc5de0a86140e2acfa00214bd6ef0242567e0 /meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb
parent8192091b461123a377d2ef64a0e75d6fbefc999a (diff)
downloadopenembedded-core-contrib-e13f651f73db0f26f4645447ab5fa17e36d1903b.tar.gz
libx11: 1.8.1 -> 1.8.3
Update libx11 from 1.8.1 to 1.8.3. * add LICENSE 'ISC' which is added by https://github.com/freedesktop/xorg-libX11/commit/a04b84f0 * adjust the ordering according to https://www.openembedded.org/wiki/Styleguide#Ordering_and_grouping Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb b/meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb
new file mode 100644
index 0000000000..06519df5da
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.8.3.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Xlib: C Language X Interface library"
+
+DESCRIPTION = "This package provides a client interface to the X Window \
+System, otherwise known as 'Xlib'. It provides a complete API for the \
+basic functions of the window system."
+
+require xorg-lib-common.inc
+
+LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116"
+
+DEPENDS += "xorgproto \
+ xtrans \
+ libxcb \
+ xorgproto-native \
+ autoconf-archive \
+ "
+
+PROVIDES = "virtual/libx11"
+
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
+
+PE = "1"
+
+XORG_PN = "libX11"
+
+SRC_URI += "file://disable_tests.patch \
+ "
+SRC_URI[sha256sum] = "e31565c84006b6b8e01dc9399c806085739710bc2db2e0930f1511ed9d6585bd"
+
+inherit gettext
+
+EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
+EXTRA_OEMAKE += 'CWARNFLAGS=""'
+
+PACKAGECONFIG ??= "xcms"
+PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
+
+PACKAGES =+ "${PN}-xcb"
+
+FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
+FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*"
+FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
+
+BBCLASSEXTEND = "native nativesdk"