summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-06-14 22:51:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-17 00:02:50 +0100
commit2d98f8d257d31b334e70357093b6d2a355362688 (patch)
tree84b0e4cc94355898c31e7425d443c0ee091ce6f4 /meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb
parenta4308b8959041a63896a01a5d79847805be5808d (diff)
downloadopenembedded-core-contrib-2d98f8d257d31b334e70357093b6d2a355362688.tar.gz
libx11: upgrade 1.7.1 -> 1.7.2
Version 1.1.2 - This is a bug fix release, correcting a regression [1] introduced by and improving the checks from the fix for CVE-2021-31535. [1] https://gitlab.freedesktop.org/xorg/lib/libx11/-/issues/133 Alan Coopersmith (1): libX11 1.7.2 Matthieu Herrb (2): include <limits.h> always, not if HAVE_CONFIG_H is set. Check for NULL strings before getting their lengths Tobias Stoeckmann (1): Protect against overly long strings Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb b/meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb
new file mode 100644
index 0000000000..383860409f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.7.2.bb
@@ -0,0 +1,45 @@
+SUMMARY = "Xlib: C Language X Interface library"
+
+DESCRIPTION = "This package provides a client interface to the X Window \
+System, otherwise known as 'Xlib'. It provides a complete API for the \
+basic functions of the window system."
+
+require xorg-lib-common.inc
+
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
+
+PE = "1"
+
+SRC_URI += "file://Fix-hanging-issue-in-_XReply.patch \
+ file://disable_tests.patch \
+ "
+
+SRC_URI[sha256sum] = "1cfa35e37aaabbe4792e9bb690468efefbfbf6b147d9c69d6f90d13c3092ea6c"
+
+PROVIDES = "virtual/libx11"
+
+XORG_PN = "libX11"
+LICENSE = "MIT & MIT-style & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
+
+DEPENDS += "xorgproto xtrans libxcb"
+DEPENDS += "xorgproto-native"
+
+EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
+EXTRA_OEMAKE += 'CWARNFLAGS=""'
+
+PACKAGECONFIG ??= "xcms"
+PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
+
+# src/util/makekeys is built natively but needs -D_GNU_SOURCE defined.
+CPPFLAGS_FOR_BUILD += "-D_GNU_SOURCE"
+
+PACKAGES =+ "${PN}-xcb"
+
+inherit gettext
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
+FILES_${PN}-xcb += "${libdir}/libX11-xcb.so.*"
+FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
+
+BBCLASSEXTEND = "native nativesdk"