summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-08-07 15:52:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 19:38:34 +0100
commit72e6919bab390494103472401a563199ab339e85 (patch)
treefe5b0d0f70e39e3a273c835895458703d22f86d0 /meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb
parent3afee08c2cdb8cda75714d7460d1c67e75f0862c (diff)
downloadopenembedded-core-contrib-72e6919bab390494103472401a563199ab339e85.tar.gz
libx11-compose-data: upgrade 1.6.7 -> 1.6.8
Refresh the patch to fix the do_patch QA warning. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb b/meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb
new file mode 100644
index 0000000000..cabb84e686
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libx11-compose-data_1.6.8.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Xlib: Compose data files for libx11"
+DESCRIPTION = "This package provides the compose data files for libx11."
+
+python () {
+ if bb.utils.contains('DISTRO_FEATURES', 'x11', True, False, d):
+ raise bb.parse.SkipRecipe("libx11-compose-data is incompatible with x11 distro feature, use libx11 instead.")
+}
+
+require xorg-lib-common.inc
+
+LICENSE = "MIT & MIT-style & BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
+
+SRC_URI[md5sum] = "c5fa5a86a20e3591bed6c046498d4b8f"
+SRC_URI[sha256sum] = "b289a845c189e251e0e884cc0f9269bbe97c238df3741e854ec4c17c21e473d5"
+
+SRC_URI += "file://0001-Drop-x11-dependencies.patch"
+
+XORG_PN = "libX11"
+
+EXTRA_OECONF += "--disable-xkb"
+
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${datadir}/X11/locale ${libdir}/X11/locale"
+
+do_compile() {
+ oe_runmake -C nls
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} -C nls install
+}
+
+REQUIRED_DISTRO_FEATURES = ""