aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-09 09:42:53 +0000
commita493de417875b62fdcf1718867ab15e8d8cc3f10 (patch)
tree4f1f4038b10049fdbfef37845cb025eb1759e276 /meta/recipes-graphics/xorg-driver
parent824d7a5d274adb0bfb0bc62601707cc970a15cdf (diff)
downloadopenembedded-core-contrib-a493de417875b62fdcf1718867ab15e8d8cc3f10.tar.gz
xf86-video-intel: add compat patch for xorg >= 1.14.99.2
(From OE-Core rev: 0d80bec421b45dc5b997eecdce3fe21f00784cd7) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel/compat-api-Map-changes-of-DamageUnregister-API-in-1..patch29
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.15.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel/compat-api-Map-changes-of-DamageUnregister-API-in-1..patch b/meta/recipes-graphics/xorg-driver/xf86-video-intel/compat-api-Map-changes-of-DamageUnregister-API-in-1..patch
new file mode 100644
index 0000000000..3a42d1377c
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel/compat-api-Map-changes-of-DamageUnregister-API-in-1..patch
@@ -0,0 +1,29 @@
+Upstream-Status: Backport
+
+From 524a45da56e2a052ffafa3887891caa90ba39f76 Mon Sep 17 00:00:00 2001
+From: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Sat, 5 Oct 2013 18:42:24 +0100
+Subject: [PATCH] compat-api: Map changes of DamageUnregister API in 1.14.99.2
+
+Reported-by: Emmanuel Benisty <benisty.e@gmail.com>
+Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+---
+ src/compat-api.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/compat-api.h b/src/compat-api.h
+index 8eb46ef..244a486 100644
+--- a/src/compat-api.h
++++ b/src/compat-api.h
+@@ -162,4 +162,8 @@ static inline void FreePixmap(PixmapPtr pixmap)
+ if ((d)->pScreen->SourceValidate) (d)->pScreen->SourceValidate(d, x, y, w, h)
+ #endif
+
++#if XORG_VERSION_CURRENT >= XORG_VERSION_NUMERIC(1,14,99,2,0)
++#define DamageUnregister(d, dd) DamageUnregister(dd)
++#endif
++
+ #endif
+--
+1.7.9.5
+
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.15.bb b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.15.bb
index 828cae842c..78edd5a5c5 100644
--- a/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.15.bb
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-intel_2.21.15.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e"
DEPENDS += "virtual/libx11 drm libpciaccess pixman"
-SRC_URI += "file://disable-dri2-tests.patch"
+SRC_URI += "file://disable-dri2-tests.patch \
+ file://compat-api-Map-changes-of-DamageUnregister-API-in-1..patch \
+ "
PACKAGECONFIG ??= "sna udev ${@base_contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)}"