aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-11-14 15:21:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-19 16:51:23 +0000
commita1d93e6383396dc3ff7cd3a4fccf27895e80af8a (patch)
treef448bc0989f957efdcf5790959987f4e4a21bbdd /meta/recipes-graphics/xorg-driver
parent6b2ffa1637d9ae067753102efeb78d1eb42a0b8a (diff)
downloadopenembedded-core-contrib-a1d93e6383396dc3ff7cd3a4fccf27895e80af8a.tar.gz
xf86-video-omap: add new recipe to follow the maintained repo
This new recipe is needed because the old driver is unmaintained. This new recipe will follow the new repo. Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb
new file mode 100644
index 0000000000..b3177ebb4d
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omap_git.bb
@@ -0,0 +1,31 @@
+require xorg-driver-video.inc
+
+SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
+
+DESCRIPTION = "omap driver supports the basic Texas Instruments OMAP \
+framebuffer."
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602"
+DEPENDS += "virtual/libx11 libdrm"
+
+RPROVIDES = "xf86-video-omapfb"
+RCONFLICTS = "xf86-video-omapfb"
+RREPLACES = "xf86-video-omapfb"
+
+SRCREV = "ae0394e687f1a77e966cf72f895da91840dffb8f"
+PR = "${INC_PR}.0"
+PV = "0.4.2+gitr${SRCPV}"
+
+SRC_URI = "git://anongit.freedesktop.org/xorg/driver/xf86-video-omap;protocol=git \
+"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF_armv7a = " --enable-neon "
+CFLAGS += " -I${STAGING_INCDIR}/xorg "
+
+# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
+do_compile_prepend_armv7a () {
+ sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
+}