aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2015-11-11 20:05:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 08:04:30 +0000
commit4ca6274aff4c7c489f148f811267634a760c5b77 (patch)
tree525c1e86f022a97c5e246513465059531f411e67 /meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb
parent15b4e5d2ab0ac117979cb367f07f444b8e123b64 (diff)
downloadopenembedded-core-contrib-4ca6274aff4c7c489f148f811267634a760c5b77.tar.gz
xf86-video-omap: Upgrade 0.4.3 -> 0.4.4
Remove backported patch. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb
new file mode 100644
index 0000000000..78954497a2
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.4.bb
@@ -0,0 +1,41 @@
+require xorg-driver-video.inc
+
+SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
+
+SUMMARY = "X.Org X server -- TI OMAP integrated graphics chipsets driver"
+
+DESCRIPTION = "Open-source X.org graphics driver for TI OMAP graphics \
+Currently relies on a closed-source submodule for EXA acceleration on \
+the following chipsets: \
+ + OMAP3430 \
+ + OMAP3630 \
+ + OMAP4430 \
+ + OMAP4460 \
+ + OMAP5430 \
+ + OMAP5432 \
+\
+NOTE: this driver is work in progress.. you probably don't want to try \
+and use it yet. The API/ABI between driver and kernel, and driver and \
+acceleration submodules is not stable yet. This driver requires the \
+omapdrm kernel driver w/ GEM support. \
+"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602"
+DEPENDS += "virtual/libx11 libdrm xf86driproto"
+
+SRC_URI[md5sum] = "a364e151a537948f75bb8c9b840a31da"
+SRC_URI[sha256sum] = "a7192690b8638f5c8d611a1bae07cc13081e22edd4070f37a2f5c3f8d79e7ebc"
+
+CFLAGS += " -I${STAGING_INCDIR}/xorg "
+
+# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
+do_compile_prepend_armv7a () {
+ sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
+}
+
+python () {
+ if not bb.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d):
+ raise bb.parse.SkipPackage("'opengl' not in DISTRO_FEATURES")
+}
+