aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-06-14 14:38:19 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-25 23:44:27 -0700
commit4ecafd89dbf41cbd53e6db32678fe625c06caaab (patch)
treee33625fa1955fd485dcd6542000af107976a5907 /meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
parentfd2c0af422d67da870a5a11720d06a871e660215 (diff)
downloadopenembedded-core-contrib-4ecafd89dbf41cbd53e6db32678fe625c06caaab.tar.gz
xinput-calibrator: move it from meta-oe to oe-core
People using xserver-xorg that need to calibrate their touchscreen devices would also need meta-oe. Bringing the recipes to oe-core will make it easier for them. Aditionaly: * drop xterm RDEPENDS. Terminal is not needed to run the menu item; * change xinput_calibrator_pointercal.sh so that it can be run as normal user: pointercal.xinput is saved to ~/.pointercal/ and it will be used when the system boots; * have the calibration run through an Xsession file; * remove the systemd service since calibration is run by Xsession; * do not install pointercal.xinput if it's the default one; [YOCTO #4416] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
new file mode 100644
index 0000000000..2e9dc03ead
--- /dev/null
+++ b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Touchscreen calibration data from xinput-calibrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r4"
+
+SRC_URI = "file://pointercal.xinput"
+S = "${WORKDIR}"
+
+do_install() {
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal.xinput ] &&\
+ [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"