aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common
diff options
context:
space:
mode:
authorWolfgang Denk <wd@denx.de>2011-01-27 12:42:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-28 17:28:24 +0000
commit97d80dd99021d975f40304f8327c330fe1a1f71b (patch)
tree8146f726681595235d026880823b48a84c9a2d6a /meta/recipes-graphics/x11-common
parenta7937d740e1f70bb7189183d93f22cb84d82c45a (diff)
downloadopenembedded-core-contrib-97d80dd99021d975f40304f8327c330fe1a1f71b.tar.gz
x11-common: Fix unusable serial console
The serial console port is basicly unusable in images containing X. Login works fine, but at the shell prompt only one out of N input characters (N usually between 2 and 10) gets through to the shell. dbus-launch (running as "dbus-launch --sh-syntax --exit-with-session") is also reading from /dev/console and "eating" the missing characters. As soon as I stop the Xserver ("sh /etc/init.d/xserver-nodm stop") the serial console starts wroking fine (because dbus-launch is not running any more). This patch addresses the problem. Signed-off-by: Wolfgang Denk <wd@denx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/x11-common')
-rw-r--r--meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession2
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession b/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession
index a87447a879..0b73127ae1 100644
--- a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession
+++ b/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xsession
@@ -2,7 +2,7 @@
if [ -x /usr/bin/dbus-launch ]; then
# As this is the X session script, always start a new DBus session.
- eval `dbus-launch --sh-syntax --exit-with-session`
+ eval `dbus-launch --sh-syntax --exit-with-session </dev/null`
echo "D-BUS per-session daemon address is: $DBUS_SESSION_BUS_ADDRESS"
fi
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index d15628560e..60b21c3b99 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xdpyinfo xtscal xinit formfactor"
-PR = "r39"
+PR = "r40"
SRC_URI = "file://etc \
file://gplv2-license.patch"