aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-10-27 16:16:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-02 08:58:01 +0000
commite8e37cff2aaac25b046236be59e86b83611330cf (patch)
tree429713c2e80ac7417fb2a7c8032213d23d0a45f5 /meta/recipes-graphics/x11-common
parentd9fc7ba254cfe3d60555fffeb09a294e1de7256b (diff)
downloadopenembedded-core-contrib-e8e37cff2aaac25b046236be59e86b83611330cf.tar.gz
xserver-nodm-init: Use useradd to add the xuser for rootless X
This also address an issue with dbus and connman, since connmand needs to start as the xuser in the rootless X situation. Fixes: [YOCTO #1699] (From OE-Core rev: 6823a32035de5d0bcd82a3b41a6ad536aaddbc58) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/x11-common')
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init.bb28
1 files changed, 10 insertions, 18 deletions
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
index ea4222df77..dbc1c42003 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
-PR = "r26"
+PR = "r28"
RDEPENDS_${PN} = "sudo"
SRC_URI = "file://xserver-nodm \
@@ -23,23 +23,15 @@ do_install() {
fi
}
-pkg_postinst_${PN} () {
- if [ "x$D" != "x" ] ; then
- exit 1
- fi
-
- if [ -f /etc/X11/Xusername ]; then
- # create the rootless X user, and add user to group tty, video, audio
- username=`cat /etc/X11/Xusername`
- adduser --disabled-password $username
- # FIXME: use addgroup if busybox addgroup is ready
- sed -i -e "s/^video:.*/&${username}/g" /etc/group
- sed -i -e "s/^tty:.*/&${username}/g" /etc/group
- sed -i -e "s/^audio:.*/&${username}/g" /etc/group
- fi
-}
-
-inherit update-rc.d
+inherit update-rc.d useradd
INITSCRIPT_NAME = "xserver-nodm"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
+
+# Use fixed Xusername of xuser for now, this will need to be
+# fixed if the Xusername changes from xuser
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM_${PN} = "--system --no-create-home \
+ --shell /bin/false --groups video,tty,audio \
+ --user-group xuser"
+