aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-12-16 15:53:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-16 16:05:37 +0000
commitccc84d94b8ff59365806b57fe90a7bacdeb16b5d (patch)
treeb8a223345372d3f3a3749a394146ca687fabc0bc /meta/recipes-graphics/x11-common
parent1855e94280bdbce2de84cb81cdd61f01950d05d9 (diff)
downloadopenembedded-core-contrib-ccc84d94b8ff59365806b57fe90a7bacdeb16b5d.tar.gz
xserver-nodm-init: Fix xuser creation
Rootless X start fail as xuser has no home and shell. This patch fix it. (From OE-Core rev: 012b6054cd5757edd6b1eb31789718bb97c26193) Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/x11-common')
-rw-r--r--meta/recipes-graphics/x11-common/xserver-nodm-init.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
index dbc1c42003..99ef72ef5a 100644
--- a/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
+++ b/meta/recipes-graphics/x11-common/xserver-nodm-init.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
-PR = "r28"
+PR = "r29"
RDEPENDS_${PN} = "sudo"
SRC_URI = "file://xserver-nodm \
@@ -31,7 +31,7 @@ INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
# Use fixed Xusername of xuser for now, this will need to be
# fixed if the Xusername changes from xuser
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --no-create-home \
- --shell /bin/false --groups video,tty,audio \
+USERADD_PARAM_${PN} = "--create-home \
+ --groups video,tty,audio \
--user-group xuser"