aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 10:49:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:45:21 +0000
commit7b70586a31e3df0ba35a7766b3b9d48e0d5d75b9 (patch)
tree41ad6cf3eac3e7172235e25bb80cbb3b07ff447a /meta/recipes-graphics/wayland
parentb7f1cca517bbd4191828c6bae32e0c5041f1ff19 (diff)
downloadopenembedded-core-contrib-7b70586a31e3df0ba35a7766b3b9d48e0d5d75b9.tar.gz
wayland: Add target sysroot scanner m4 macro
With the new aclocals process, accesses to the macros is a lot stricter and the native macros are not used. We need to ensure the modified macros are used in target builds to get the correct scanner functionality. Inserting the native macro into the target is the correct thing to do in this case. This resolves build failures in libva. (From OE-Core rev: ad9bd9ce164c9cb1212de27fec84ad0fe5214bb2) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.4.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.4.0.bb b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
index 0f08cacfea..604b7f4c54 100644
--- a/meta/recipes-graphics/wayland/wayland_1.4.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.4.0.bb
@@ -34,3 +34,7 @@ do_install_append_class-native() {
-e 's,$PKG_CONFIG,pkg-config-native,g' \
-i ${D}/${datadir}/aclocal/wayland-scanner.m4
}
+
+sysroot_stage_all_append_class-target () {
+ cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}