aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-11-07 11:55:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:31:35 +0000
commit44121975a65a0382c61aecf99495177c21fc244a (patch)
tree3a15bdd2b5dec1205f83cf0996450e3a0542fd7a /meta/recipes-graphics/wayland
parentf6484887ba2a2bb3133276afc04c027d081e8f92 (diff)
downloadopenembedded-core-contrib-44121975a65a0382c61aecf99495177c21fc244a.tar.gz
weston-init: start weston on a new VT
Weston 1.3 needs to run on a VT, which is typically handled by weston-launch. Currently weston-init doesn't use weston-launch as that depends on the (non-default) pam DISTRO_FEATURE, so depend on kbd and use openvt directly. This also fixes problems caused by the init script blocking until Weston exits, which meant that later init scripts were not actually running. (From OE-Core rev: 3726eb29cfa79a4a1fbdbcaa96f770063c482858) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb2
-rw-r--r--meta/recipes-graphics/wayland/weston-init/init2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index a3fe811f4d..4ebda8b297 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -13,5 +13,7 @@ do_install() {
inherit allarch update-rc.d
+RDEPENDS_${PN} = "weston kbd"
+
INITSCRIPT_NAME = "weston"
INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
diff --git a/meta/recipes-graphics/wayland/weston-init/init b/meta/recipes-graphics/wayland/weston-init/init
index daa7f2300f..284fd0ac3c 100644
--- a/meta/recipes-graphics/wayland/weston-init/init
+++ b/meta/recipes-graphics/wayland/weston-init/init
@@ -34,7 +34,7 @@ case "$1" in
chmod 0700 $XDG_RUNTIME_DIR
fi
- weston
+ openvt -s weston
;;
stop)