aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston_1.8.0.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-10-20 10:33:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:20:13 +0000
commitf51ba9a89ee8cede03b5b7834579fd63fa483267 (patch)
treefc78515a00003794560036f3e9c8ee0cf50917f3 /meta/recipes-graphics/wayland/weston_1.8.0.bb
parentb64c5114f304186858b54c5f248245ab98772373 (diff)
downloadopenembedded-core-contrib-f51ba9a89ee8cede03b5b7834579fd63fa483267.tar.gz
weston: add PACKAGECONFIG to build with systemd-login support
Automatically enable this support for distributions which have systemd in DISTRO_FEATURES. We add additional patches to weston, backported from Weston git, to support the newer single libsystemd pkg-config file and to make the enabling of systemd-login support explicit. Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.8.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.8.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.8.0.bb b/meta/recipes-graphics/wayland/weston_1.8.0.bb
index 95cf4956da..6234a8c6f5 100644
--- a/meta/recipes-graphics/wayland/weston_1.8.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.8.0.bb
@@ -12,6 +12,8 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
file://make-libwebp-explicitly-configurable.patch \
file://0001-make-error-portable.patch \
file://parallelmake.patch \
+ file://libsystemd.patch \
+ file://explicit-enable-disable-systemd.patch \
"
SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"
@@ -41,6 +43,7 @@ EXTRA_OECONF_append_qemux86-64 = "\
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
"
#
# Compositor choices
@@ -69,6 +72,8 @@ PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
# Weston with unwinding support
PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
+# Weston with systemd-login support
+PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus"
do_install_append() {
# Weston doesn't need the .la files to load modules, so wipe them