aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston-init.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-18 13:40:45 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-21 22:21:30 +0100
commit3e7c4d06aaa1fccc1a18f4431122603cc4a9bbe9 (patch)
tree41b1fbb24d9b63c1947b1a6a6789b17bc8cf612d /meta/recipes-graphics/wayland/weston-init.bb
parent2332f93ae88ca4e4a5aac1806f21104b6489b3bb (diff)
downloadopenembedded-core-contrib-3e7c4d06aaa1fccc1a18f4431122603cc4a9bbe9.tar.gz
weston-init: Add module support for the weston-start helper
To make weston-start more flexible we now support module loading. For such modules, following functions can be used: - add_weston_argument - add_openvt_argument Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston-init.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston-init.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 3a2251e69a..e4e2701af7 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -11,7 +11,10 @@ S = "${WORKDIR}"
do_install() {
install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston
install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+
+ # Install weston-start script
install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
+ sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
}
inherit allarch update-rc.d distro_features_check systemd