aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.8.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-07-01 23:04:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-02 23:07:26 +0100
commit7aeeaf287169d4d7de5349626caa93a3941c2c35 (patch)
treedf3a33b21983843d95467f8bb8c2e26006bfc651 /meta/recipes-graphics/wayland/wayland_1.8.1.bb
parent430dd1437a4196c11973cf9ef0d2dad1f2063a7f (diff)
downloadopenembedded-core-contrib-7aeeaf287169d4d7de5349626caa93a3941c2c35.tar.gz
wayland: always build wayland-scanner
By passing --disable-scanner to use a native wayland-scanner binary a target wayland-scanner binary isn't built, which is a problem if you want to use it on the target or in a SDK. Instead, always build a target wayland-scanner binary, and have an option to control whether that binary or a host-provided binary is used at build time. [ YOCTO #7931 ] Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.8.1.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.8.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.8.1.bb b/meta/recipes-graphics/wayland/wayland_1.8.1.bb
index 5b367453cc..ac631af1fb 100644
--- a/meta/recipes-graphics/wayland/wayland_1.8.1.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.8.1.bb
@@ -10,14 +10,15 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=1d4476a7d98dd5691c53d4d43a510c72 \
file://src/wayland-server.c;endline=21;md5=079ae21dbf98ada52ec23744851b0a5c"
-SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+ file://always-build-scanner.patch"
SRC_URI[md5sum] = "6e877877c3e04cfb865cfcd0733c9ab1"
SRC_URI[sha256sum] = "f17c938d1c24fd0a10f650a623a2775d329db3168b5732e498b08388ec776fc8"
SRC_URI_append_class-native = " \
file://disable-macro-checks-not-used-for-scanner.patch \
"
-EXTRA_OECONF_class-native = "--disable-documentation --enable-scanner"
+EXTRA_OECONF_class-native = "--disable-documentation"
inherit autotools pkgconfig
@@ -26,7 +27,7 @@ BBCLASSEXTEND = "native"
DEPENDS = "expat libffi wayland-native"
-EXTRA_OECONF = "--disable-documentation --disable-scanner"
+EXTRA_OECONF = "--disable-documentation --with-host-scanner"
# Wayland installs a M4 macro for other projects to use, which uses the target
# pkg-config to find files. Replace pkg-config with pkg-config-native.
@@ -40,3 +41,6 @@ sysroot_stage_all_append_class-target () {
rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
}
+
+FILES_${PN} = "${libdir}/*${SOLIBS}"
+FILES_${PN}-dev += "${bindir} ${datadir}/wayland"