summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.18.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-13 01:23:44 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-14 13:04:49 +0000
commitc127e7ac7c6da11417a599384002fd7c1420c7c2 (patch)
treef6cd7ac1b47720cd677cad6cb0cdd2935c666023 /meta/recipes-graphics/wayland/wayland_1.18.0.bb
parentb01505e018ff46f1af34f98219d55f4ca700cd5a (diff)
downloadopenembedded-core-contrib-c127e7ac7c6da11417a599384002fd7c1420c7c2.tar.gz
wayland: upgrade 1.17.0 -> 1.18.0
This is the official release for Wayland 1.18. The main new features in this release are: - Add support for the Meson build system (autotools is still supported but will be removed in a future release) - Add API to tag proxy objects to allow applications and toolkits to share the same Wayland connection - Track wayland-server timers in user-space to prevent creating too many FDs - Add wl_global_remove, a new function to mitigate race conditions with globals https://lists.freedesktop.org/archives/wayland-devel/2020-February/041207.html 2 upstreamed patches are dropped. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.18.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.18.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.18.0.bb b/meta/recipes-graphics/wayland/wayland_1.18.0.bb
new file mode 100644
index 0000000000..7a3f075552
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.18.0.bb
@@ -0,0 +1,47 @@
+SUMMARY = "Wayland, a protocol between a compositor and clients"
+DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
+as well as a C library implementation of that protocol. The compositor can be \
+a standalone display server running on Linux kernel modesetting and evdev \
+input devices, an X application, or a wayland client itself. The clients can \
+be traditional applications, X servers (rootless or fullscreen) or other \
+display servers."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
+ file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
+
+DEPENDS = "expat libffi wayland-native"
+
+SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+ file://fixpathinpcfiles.patch \
+ "
+SRC_URI[md5sum] = "23317697b6e3ff2e1ac8c5ba3ed57b65"
+SRC_URI[sha256sum] = "4675a79f091020817a98fd0484e7208c8762242266967f55a67776936c2e294d"
+
+UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "dtd-validation"
+PACKAGECONFIG[dtd-validation] = "--enable-dtd-validation,--disable-dtd-validation,libxml2,,"
+
+EXTRA_OECONF = "--disable-documentation --with-host-scanner"
+EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
+
+# Wayland installs a M4 macro for other projects to use, which uses the target
+# pkg-config to find files. Replace pkg-config with pkg-config-native.
+do_install_append_class-native() {
+ sed -e 's,PKG_CHECK_MODULES(.*),,g' \
+ -e 's,$PKG_CONFIG,pkg-config-native,g' \
+ -i ${D}/${datadir}/aclocal/wayland-scanner.m4
+}
+
+sysroot_stage_all_append_class-target () {
+ rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
+ cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}
+
+FILES_${PN} = "${libdir}/*${SOLIBS}"
+FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
+
+BBCLASSEXTEND = "native nativesdk"