aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland_1.10.0.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-05-16 16:22:48 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-17 14:43:06 +0100
commit7d278ef0a28f47c75570f0f9c5d627d07f925045 (patch)
tree27af8961d1dd70d4768dc473826e280e67ec4244 /meta/recipes-graphics/wayland/wayland_1.10.0.bb
parentc99e920a344b29e053781008faa0328f416fdcc4 (diff)
downloadopenembedded-core-contrib-7d278ef0a28f47c75570f0f9c5d627d07f925045.tar.gz
wayland: Upgrade 1.9.0 -> 1.10.0
Yes, Wayland now depends on another xml parser (just for build time dtd validation). Use HTTPS for tarball uri. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland_1.10.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.10.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.10.0.bb b/meta/recipes-graphics/wayland/wayland_1.10.0.bb
new file mode 100644
index 0000000000..41d08b7e25
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland_1.10.0.bb
@@ -0,0 +1,41 @@
+SUMMARY = "Wayland, a protocol between a compositor and clients"
+DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
+as well as a C library implementation of that protocol. The compositor can be \
+a standalone display server running on Linux kernel modesetting and evdev \
+input devices, an X application, or a wayland client itself. The clients can \
+be traditional applications, X servers (rootless or fullscreen) or other \
+display servers."
+HOMEPAGE = "http://wayland.freedesktop.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
+ file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
+
+SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI[md5sum] = "e7751c38807c231afaba9d6b68f2a2b7"
+SRC_URI[sha256sum] = "4bf6e790aa6f50ab3825676282ecd75850ec9c4767af96ecb7127b1f3c3d60dc"
+
+EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"
+
+DEPENDS = "expat libxml2 libffi wayland-native"
+
+EXTRA_OECONF = "--disable-documentation --with-host-scanner"
+
+# Wayland installs a M4 macro for other projects to use, which uses the target
+# pkg-config to find files. Replace pkg-config with pkg-config-native.
+do_install_append_class-native() {
+ sed -e 's,PKG_CHECK_MODULES(.*),,g' \
+ -e 's,$PKG_CONFIG,pkg-config-native,g' \
+ -i ${D}/${datadir}/aclocal/wayland-scanner.m4
+}
+
+sysroot_stage_all_append_class-target () {
+ rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
+ cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}
+
+FILES_${PN} = "${libdir}/*${SOLIBS}"
+FILES_${PN}-dev += "${bindir} ${datadir}/wayland"