aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_0.18.0.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-08-05 12:19:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-09 15:14:30 -0700
commit3ffbceb4394a54c4b02fa66525b2a00832d4e7f1 (patch)
treebde40ca5670e1e9c33794867b324d1d69cb92b24 /meta/recipes-graphics/wayland/libinput_0.18.0.bb
parentd5d905caf5fc5dc71e393a9d875c9ab5188c4c93 (diff)
downloadopenembedded-core-contrib-3ffbceb4394a54c4b02fa66525b2a00832d4e7f1.tar.gz
libinput: add configure arg and PACKAGECONFIG for libunwind
libinput uses pkg-config to check and decide whether to build with libunwind, which causes undeterministic builds or error: | tmp/work/core2-64-wrs-linux/libinput/0.18.0-r0/libinput-0.18.0/test/litest.c:77:23: | fatal error: libunwind.h: No such file or directory So add configure arg and PACKAGECONFIG for libunwind to make deterministic build, but libunwind is disabled by default. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_0.18.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_0.18.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_0.18.0.bb b/meta/recipes-graphics/wayland/libinput_0.18.0.bb
index 0fe1c6c59b..8e8e6a7c41 100644
--- a/meta/recipes-graphics/wayland/libinput_0.18.0.bb
+++ b/meta/recipes-graphics/wayland/libinput_0.18.0.bb
@@ -7,11 +7,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=2184aef38ff137ed33ce9a63b9d1eb8f"
DEPENDS = "libevdev udev mtdev"
-SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz"
+SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
+ file://libinput-configure.ac-add-arg-with-libunwind.patch \
+"
SRC_URI[md5sum] = "0ddbb0d53d58dec0a86de6791560011a"
SRC_URI[sha256sum] = "64a70f96bab17a22eaf2fd7af17cf83def3388374096c7623be9448f62808cda"
inherit autotools pkgconfig
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
+
FILES_${PN} += "${libdir}/udev/"
FILES_${PN}-dbg += "${libdir}/udev/.debug"