summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/waffle
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:30:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:12 +0100
commit908f6f2ded18d5301f428e685bface60335bd791 (patch)
tree45bd4a0b8bf2f1640a7ff4d3a1a39c01db917cd1 /meta/recipes-graphics/waffle
parente66f1c830bfee09ed9a043ade5374fe61fea3c99 (diff)
downloadopenembedded-core-contrib-908f6f2ded18d5301f428e685bface60335bd791.tar.gz
recipes-graphics: add x11 to REQUIRED_DISTRO_FEATURES
They can't be built withou x11 in DISTRO_FEATURES. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-graphics/waffle')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.3.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.3.0.bb b/meta/recipes-graphics/waffle/waffle_1.3.0.bb
index fe9609c5b0..a21fcbb302 100644
--- a/meta/recipes-graphics/waffle/waffle_1.3.0.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.3.0.bb
@@ -7,12 +7,15 @@ SRC_URI = "http://people.freedesktop.org/~chadversary/waffle/files/release/${BPN
SRC_URI[md5sum] = "5020ecc249096c881e1f59ee961f3d41"
SRC_URI[sha256sum] = "340ee04172dba878249469018cd7ec9d1ecd41af26b612c741b8b52e713bca8e"
-inherit cmake
+inherit cmake distro_features_check
# This should be overridden per-machine to reflect the capabilities of the GL
# stack.
PACKAGECONFIG ??= "glx"
+# libx11 requires x11 in DISTRO_FEATURES.
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
+
# I say virtual/libgl, actually wants gl.pc
PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,,virtual/libgl libx11"