summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/waffle/waffle_1.7.0.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2021-11-15 01:04:40 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-16 22:19:47 +0000
commit19753e7fff81a4252d0095b54d37d52db11e3f56 (patch)
tree50342e895ac781341fa2e28b2a90eae63c1eabf2 /meta/recipes-graphics/waffle/waffle_1.7.0.bb
parent567e199862acb948cb8b3361010a9ec221147c41 (diff)
downloadopenembedded-core-contrib-19753e7fff81a4252d0095b54d37d52db11e3f56.tar.gz
waffle: add cmake-native to DEPENDS
waffle currently requires cmake-native because it has the following lines in git/src/waffle/meson.build. if meson.version().version_compare('>= 0.50') cmake = import('cmake') In case of 'wayland' not being in DISTRO_FEATURES, we will get the following error at do_configure. | ../git/src/waffle/meson.build:233:8: ERROR: Unable to find cmake So explictly add 'cmake-native' to DEPENDS to solve this problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/waffle/waffle_1.7.0.bb')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.7.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.7.0.bb b/meta/recipes-graphics/waffle/waffle_1.7.0.bb
index 6284af3076..ea11309940 100644
--- a/meta/recipes-graphics/waffle/waffle_1.7.0.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.7.0.bb
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git"
inherit meson features_check lib_package bash-completion pkgconfig
-DEPENDS:append = " python3"
+DEPENDS:append = " python3 cmake-native"
# This should be overridden per-machine to reflect the capabilities of the GL
# stack.