summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/vulkan
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-05-03 10:54:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 11:07:21 +0100
commit7484c71ca3a932bcb4c3679e25b0233c06be4404 (patch)
treeeb07f1a009996227e40a532df825f3d97ee371cf /meta/recipes-graphics/vulkan
parent1a435cb3e6cf3450867f6a591c1e3ceb4918a97d (diff)
downloadopenembedded-core-contrib-7484c71ca3a932bcb4c3679e25b0233c06be4404.tar.gz
vulkan: add a comment explaining upstream version policy
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/vulkan')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb4
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-loader_1.3.239.0.bb4
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-tools_1.3.239.0.bb4
3 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
index a6b30fa831..19b13bce63 100644
--- a/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.239.0.bb
@@ -20,4 +20,8 @@ inherit cmake
FILES:${PN} += "${datadir}/vulkan"
RDEPENDS:${PN} += "python3-core"
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
diff --git a/meta/recipes-graphics/vulkan/vulkan-loader_1.3.239.0.bb b/meta/recipes-graphics/vulkan/vulkan-loader_1.3.239.0.bb
index e11f936a0a..e45996e5a5 100644
--- a/meta/recipes-graphics/vulkan/vulkan-loader_1.3.239.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-loader_1.3.239.0.bb
@@ -35,4 +35,8 @@ PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SU
RRECOMMENDS:${PN} = "mesa-vulkan-drivers"
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
diff --git a/meta/recipes-graphics/vulkan/vulkan-tools_1.3.239.0.bb b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.239.0.bb
index 934bd53ee1..5dc6bcad45 100644
--- a/meta/recipes-graphics/vulkan/vulkan-tools_1.3.239.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.239.0.bb
@@ -29,4 +29,8 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF, libxcb libx11 libxrandr"
PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"