aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2013-03-15 16:04:02 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-16 17:13:57 +0000
commit7720c356534e46614578619d5a8f0462485b81f6 (patch)
treedfbcedd8175b6d4aa37557d63d046a04a2f57a53 /meta/recipes-graphics/ttf-fonts
parent9dbff379575e6f5fdc07412906848134b2739598 (diff)
downloadopenembedded-core-contrib-7720c356534e46614578619d5a8f0462485b81f6.tar.gz
ttf-fonts: fix PN -> BPN in do_install for multilibs
Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb6
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb6
-rw-r--r--meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb6
3 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
index 67e36e2a01..a34825ab19 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
@@ -9,7 +9,7 @@ SECTION = "x11/fonts"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
RDEPENDS_${PN} = "fontconfig-utils"
-PR = "r3"
+PR = "r4"
PE = "1"
inherit allarch fontcache
@@ -31,8 +31,8 @@ do_install () {
install -d ${D}${sysconfdir}/fonts/conf.d/
install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
- install -d ${D}${prefix}/share/doc/${PN}/
- install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
+ install -d ${D}${prefix}/share/doc/${BPN}/
+ install -m 0644 License.txt ${D}${datadir}/doc/${BPN}/
}
PACKAGES = "${PN}"
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
index 0ac4debcd6..6391f51227 100644
--- a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
@@ -10,7 +10,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
RDEPENDS_${PN} = "fontconfig-utils"
PE = "1"
-PR = "r2"
+PR = "r3"
FONTREV = "0.20100721"
SRC_URI = "https://fedorahosted.org/releases/l/i/${BPN}/${BPN}-${PV}.${FONTREV}.tar.gz \
@@ -29,8 +29,8 @@ do_install () {
install -d ${D}${sysconfdir}/fonts/conf.d/
install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
- install -d ${D}${prefix}/share/doc/${PN}/
- install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
+ install -d ${D}${prefix}/share/doc/${BPN}/
+ install -m 0644 License.txt ${D}${datadir}/doc/${BPN}/
}
pkg_postinst_${PN} () {
diff --git a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
index 6214c16278..71e85e4088 100644
--- a/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
+++ b/meta/recipes-graphics/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -7,7 +7,7 @@ but is visibly different than normal and bold, and reasonably pleasing."
SECTION = "x11/fonts"
LICENSE = "BitstreamVera"
LIC_FILES_CHKSUM = "file://COPYRIGHT.TXT;md5=27d7484b1e18d0ee4ce538644a3f04be"
-PR = "r6"
+PR = "r7"
RDEPENDS_${PN} = "fontconfig-utils"
inherit allarch
@@ -25,9 +25,9 @@ do_install () {
#install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
- install -d ${D}${prefix}/share/doc/${PN}/
+ install -d ${D}${prefix}/share/doc/${BPN}/
for i in *.TXT; do
- install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ install -m 644 $i ${D}${prefix}/share/doc/${BPN}/$i
done
}