aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-05-03 16:11:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-16 14:08:19 +0100
commit9b60def67028df65fa8894c49cf09e601f1670df (patch)
tree568970485cbce0b4fdb36b1cd297669cad71b947 /meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
parenta89da82567f95d4fcd467003359ebcd13571fc0d (diff)
downloadopenembedded-core-contrib-9b60def67028df65fa8894c49cf09e601f1670df.tar.gz
liberation-fonts: update to 2.00.1
'fontforge issue' was actually a non-issue; fontforge is required only when building ttf fonts from sfd source. We took prebuilt ttf fonts when using 1.04 version, and can do the same thing with 2.00.1 version, it's just that the tarball name for prebuilt fonts has slightly changed and no one noticed somehow. License has changed from GPLv2 to Open Font License v.1.1 Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb')
-rw-r--r--meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
new file mode 100644
index 0000000000..412da48725
--- /dev/null
+++ b/meta/recipes-graphics/ttf-fonts/liberation-fonts_2.00.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Liberation(tm) Fonts"
+DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
+created by Ascender(c) which aims at metric compatibility with \
+Arial, Times New Roman, Courier New."
+HOMEPAGE = "https://releases.pagure.org/liberation-fonts/"
+BUGTRACKER = "https://bugzilla.redhat.com/"
+
+SECTION = "x11/fonts"
+LICENSE = "OFL-1.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b"
+PE = "1"
+
+inherit allarch fontcache
+
+FONT_PACKAGES = "${PN}"
+
+SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
+ file://30-liberation-aliases.conf"
+
+S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
+
+SRC_URI[md5sum] = "5c781723a0d9ed6188960defba8e91cf"
+SRC_URI[sha256sum] = "7890278a6cd17873c57d9cd785c2d230d9abdea837e96516019c5885dd271504"
+
+do_install () {
+ install -d ${D}${datadir}/fonts/ttf/
+ for i in *.ttf; do
+ install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ install -d ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
+
+ install -d ${D}${prefix}/share/doc/${BPN}/
+ install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${sysconfdir} ${datadir}"