summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-06 16:23:34 +0000
commitd3d0375fa0b4809d2c69837faf5df297d92de683 (patch)
treeaeb13075692d62850d9c90f68810a3e0093aeaac /meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
parent7235073a7ee2fb371931922c2d0f28ab09673102 (diff)
downloadopenembedded-core-contrib-d3d0375fa0b4809d2c69837faf5df297d92de683.tar.gz
vulkan: upgrade 1.3.268.0 -> 1.3.275.0
Add vulkan-volk recipe to support building latest vulkan-tools. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb')
-rw-r--r--meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb b/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
new file mode 100644
index 0000000000..598a8fc209
--- /dev/null
+++ b/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Machine-readable files for the SPIR-V Registry"
+SECTION = "graphics"
+HOMEPAGE = "https://www.khronos.org/registry/spir-v"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
+
+SRCREV = "1c6bb2743599e6eb6f37b2969acc0aef812e32e3"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=main"
+PE = "1"
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
+# vulkan-validation-layers, vulkan-utility-libraries.
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+BBCLASSEXTEND = "native nativesdk"