aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-14 15:08:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:08:43 +0100
commite53d09e265a217928e1436208e0f9057aa8ef7ae (patch)
treecea53d95cd4249e5c77ca602f87c36fb6a7dbc89 /meta/recipes-graphics/piglit/piglit_git.bb
parenta2e7a94f8d777d1cd9a07e1543b88a0cf1f9cd67 (diff)
downloadopenembedded-core-contrib-e53d09e265a217928e1436208e0f9057aa8ef7ae.tar.gz
piglit: Fix floating dependency on freeglut
71158fa1a623125[fix floating dependence on freeglut] is incomplete, so continue by removing glut.h header file when not enable freeglut Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 3a8b0acfa2..0d825c9818 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -24,6 +24,7 @@ PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
do_configure_prepend() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
+ sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
fi
}