aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-14 15:19:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 16:21:37 +0000
commitcab8dad6f3b14f21115a765a4e55d38a0f73f337 (patch)
tree0b97ecc62fae071212c5642dfe1acb57b66386ba /meta/recipes-graphics/piglit/piglit_git.bb
parent67228f682cb8acc71dd5f8b44af67f529727f780 (diff)
downloadopenembedded-core-contrib-cab8dad6f3b14f21115a765a4e55d38a0f73f337.tar.gz
piglit: add (from meta-oe)
Piglit is an OpenGL testing tool. This recipe is taken directly from meta-oe. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
new file mode 100644
index 0000000000..8616764fc5
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -0,0 +1,48 @@
+SUMMARY = "OpenGL driver testing framework"
+LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
+
+SRC_URI = "git://anongit.freedesktop.org/piglit"
+
+# From 2012/12/30.
+SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268"
+# (when PV goes above 1.0 remove the trailing r)
+PV = "1.0+gitr${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "virtual/libx11 waffle virtual/libgl libglu python-mako-native python-numpy-native"
+
+inherit cmake pythonnative
+
+# As piglit doesn't install, enforce in-tree builds so that we can easily copy
+# contents out of $S and $B.
+B="${S}"
+
+# CMake sets the rpath at build time with the source tree, and will reset it at
+# install time. As we don't install this doesn't happen, so force the rpath to
+# what we need.
+EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 piglit-*.py ${D}${bindir}
+
+ install -d ${D}${libdir}/piglit/
+
+ install -d ${D}${libdir}/piglit/bin
+ install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin
+
+ cp -a lib/ ${D}${libdir}/piglit/
+ cp -a framework/ ${D}${libdir}/piglit/
+ cp -a generated_tests/ ${D}${libdir}/piglit/
+ cp -a tests/ ${D}${libdir}/piglit/
+ cp -a templates/ ${D}${libdir}/piglit/
+
+ sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py
+ sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py
+}
+
+FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
+
+RDEPENDS_${PN} = "python waffle python-json python-subprocess python-multiprocessing python-textutils python-netserver python-shell mesa-demos"