aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/piglit/piglit
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-09-13 11:46:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-14 22:20:05 +0100
commitcd67959c4794b132cb9fd20a2a37cf862e172bed (patch)
treedc29622f4ab64fdbc52385de3e611f4cefe30a24 /meta/recipes-graphics/piglit/piglit
parentec33043477a0b915b0911f7d7eacb24361e4aaa8 (diff)
downloadopenembedded-core-contrib-cd67959c4794b132cb9fd20a2a37cf862e172bed.tar.gz
piglit: Backport linker flag patch
Use the correct build system patch instead of adding linker flags in recipe. Also update upstream status for the other build patch. Fixes [YOCTO #9851]. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/piglit/piglit')
-rw-r--r--meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch41
-rw-r--r--meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch2
2 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch b/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch
new file mode 100644
index 0000000000..2e1c9476f2
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-test-utils-with-ldl.patch
@@ -0,0 +1,41 @@
+Backport patch to fix build with gold linker.
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Upstream-Status: Backport
+
+
+
+From 93a7113485cf1c55fd7076116faf5b3a690706b2 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Tue, 30 Aug 2016 17:17:28 +0300
+Subject: [PATCH] cmake: Link test utils with "-ldl"
+
+Without this linking CXX executables (e.g. fbo-blit-stretch) fails
+with gold linker:
+
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlsym'
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlerror'
+| libpiglitutil_gl.so.0: error: undefined reference to 'dlopen'
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
+---
+ tests/util/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/util/CMakeLists.txt b/tests/util/CMakeLists.txt
+index e1f8073..3d5bef5 100644
+--- a/tests/util/CMakeLists.txt
++++ b/tests/util/CMakeLists.txt
+@@ -11,6 +11,8 @@ set_source_files_properties(
+ PROPERTIES GENERATED 1
+ )
+
++link_libraries(${CMAKE_DL_LIBS})
++
+ if(HAVE_LIBCACA)
+ link_libraries(caca)
+ endif()
+--
+2.9.3
+
diff --git a/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch b/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch
index d591da5d6b..845804dd66 100644
--- a/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch
+++ b/meta/recipes-graphics/piglit/piglit/0001-cmake-Link-utils-with-xcb-explicitly.patch
@@ -13,7 +13,7 @@ This may have appeared now because xcb-dri2 used to overlink publicly
but now does not.
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
-Upstream-Status: Pending
+Upstream-Status: Accepted
---
CMakeLists.txt | 1 +
tests/util/CMakeLists.txt | 2 ++