aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-30 12:04:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:52:58 +0100
commit8eba44660e495702fc68244fba64b6f08c1c9418 (patch)
treedaa1e146223f1496654a3858951cea60e7f55ebf /meta/recipes-graphics/packagegroups
parentd56f6af12cf94882b192b8da347a1c0bcd85602f (diff)
downloadopenembedded-core-contrib-8eba44660e495702fc68244fba64b6f08c1c9418.tar.gz
packagegroup-core-x11*: adjust X11 package groups
Now the Sato pieces have been moved out, rebase packagegroup-core-x11 on packagegroup-x11-mini but using the structure/contents of meta-oe's task-x11 so that it can replace that; rename packagegroup-core-x11-mini to packagegroup-core-x11-base and pull in the xserver/utils packages via packagegroup-core-x11, and move both of these recipes under recipes-graphics. x11-mini is renamed to x11-base as it's what people should build on top of and since x11-mini is newer, the corresponding IMAGE_FEATURES item is less likely to be used in existing user recipes. (From OE-Core rev: 0cc9ced7d96b960994b0671095bc74becfc55e2c) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/packagegroups')
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb18
-rw-r--r--meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb41
2 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
new file mode 100644
index 0000000000..eb4b27dc4c
--- /dev/null
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+inherit packagegroup
+
+RDEPENDS_${PN} = "\
+ packagegroup-core-x11-xserver \
+ packagegroup-core-x11-utils \
+ dbus \
+ pointercal \
+ matchbox-terminal \
+ matchbox-wm \
+ mini-x-session \
+ liberation-fonts \
+ "
diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
new file mode 100644
index 0000000000..9563de0783
--- /dev/null
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r36"
+
+inherit packagegroup
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PACKAGES = "${PN} ${PN}-xserver ${PN}-utils"
+
+XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+RDEPENDS_${PN} = "\
+ ${PN}-xserver \
+ ${PN}-utils \
+ "
+
+RDEPENDS_${PN}-xserver = "\
+ ${XSERVER} \
+ "
+
+RDEPENDS_${PN}-utils = "\
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ "