aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mx/mx-1.0
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-09-29 15:36:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-30 20:58:03 +0100
commit11bc6489d534ecf904b04ab9e9b6415d4415492a (patch)
treeb3ecfd89679778fab3671c512068b21c5ec32d5a /meta/recipes-graphics/mx/mx-1.0
parent9a17f938e738a16a1ef9a00be6a8317d71f92573 (diff)
downloadopenembedded-core-contrib-11bc6489d534ecf904b04ab9e9b6415d4415492a.tar.gz
mx: remove version from patch directory
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mx/mx-1.0')
-rw-r--r--meta/recipes-graphics/mx/mx-1.0/fix-build-dir.patch46
-rw-r--r--meta/recipes-graphics/mx/mx-1.0/fix-test-includes.patch20
2 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mx/mx-1.0/fix-build-dir.patch b/meta/recipes-graphics/mx/mx-1.0/fix-build-dir.patch
new file mode 100644
index 0000000000..3c8a832021
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.0/fix-build-dir.patch
@@ -0,0 +1,46 @@
+Fix build for S != B
+
+This patch is specific to version 1.4.x
+Upstream-Status: Submitted @ https://github.com/clutter-project/mx/issues/81
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/docs/reference/libmx-gtk/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:14:33.684318650 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -77,7 +80,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx-gtk/libmx-gtk-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
+Index: git/docs/reference/libmx/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx/Makefile.am 2013-05-08 15:14:24.456378135 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -106,7 +109,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx/libmx-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
diff --git a/meta/recipes-graphics/mx/mx-1.0/fix-test-includes.patch b/meta/recipes-graphics/mx/mx-1.0/fix-test-includes.patch
new file mode 100644
index 0000000000..82c93dd604
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.0/fix-test-includes.patch
@@ -0,0 +1,20 @@
+Fix missing include directory when building tests
+
+This patch is currently required for all versions of mx
+Upstream-Status: Submitted @ https://github.com/clutter-project/mx/issues/82
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/tests/Makefile.am
+===================================================================
+--- git.orig/tests/Makefile.am 2013-05-08 15:18:56.918596425 +0100
++++ git/tests/Makefile.am 2013-05-08 15:23:26.864781401 +0100
+@@ -10,7 +10,8 @@
+
+ INCLUDES = \
+ -I$(top_srcdir) \
+- -I$(top_builddir)
++ -I$(top_builddir)\
++ -I$(top_builddir)/mx
+
+ noinst_PROGRAMS = \
+ test-deform-texture \