aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2013-10-17 16:58:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:48:48 +0100
commitcc41cb61707da1b4ae029de70c922802067166c2 (patch)
tree70f6fad1514611992265075cee1428f62f79f9c1 /meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806
parentb7de1eaac9eed559b2d68058f5de67de74a6cb58 (diff)
downloadopenembedded-core-contrib-cc41cb61707da1b4ae029de70c922802067166c2.tar.gz
clutter: remove usage of FILESPATH
Usage of FILESPATH is discouraged, since it can make recipes harder to bbappend. Instead FILESEXTRAPATHS should be used to extend the path. However in clutter the default paths solves the problem if we put all patches in ${BP} directory instead. Signed-off-by: Petter Mabäcker <petter@technux.se> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806')
-rw-r--r--meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-build-dir.patch46
-rw-r--r--meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-test-includes.patch20
2 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-build-dir.patch b/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-build-dir.patch
new file mode 100644
index 0000000000..3c8a832021
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-build-dir.patch
@@ -0,0 +1,46 @@
+Fix build for S != B
+
+This patch is specific to version 1.4.x
+Upstream-Status: Submitted @ https://github.com/clutter-project/mx/issues/81
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/docs/reference/libmx-gtk/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx-gtk/Makefile.am 2013-05-08 15:14:33.684318650 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -77,7 +80,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx-gtk/libmx-gtk-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
+Index: git/docs/reference/libmx/Makefile.am
+===================================================================
+--- git.orig/docs/reference/libmx/Makefile.am 2013-05-08 15:07:02.027154788 +0100
++++ git/docs/reference/libmx/Makefile.am 2013-05-08 15:14:24.456378135 +0100
+@@ -1,3 +1,6 @@
++EXTRA_DIST=
++CLEANFILES=
++
+ ## Process this file with automake to produce Makefile.in
+
+ # We require automake 1.6 at least.
+@@ -106,7 +109,7 @@
+ GTKDOC_LIBS=$(MX_LIBS) $(top_builddir)/mx/libmx-$(MX_API_VERSION).la
+
+ # This includes the standard gtk-doc make rules, copied by gtkdocize.
+-include $(top_srcdir)/gtk-doc.make
++include $(top_builddir)/gtk-doc.make
+
+ # Other files to distribute
+ EXTRA_DIST += version.xml.in
diff --git a/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-test-includes.patch b/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-test-includes.patch
new file mode 100644
index 0000000000..82c93dd604
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx-1.0-1.4.7+gitAUTOINC+9b1db6b806/fix-test-includes.patch
@@ -0,0 +1,20 @@
+Fix missing include directory when building tests
+
+This patch is currently required for all versions of mx
+Upstream-Status: Submitted @ https://github.com/clutter-project/mx/issues/82
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/tests/Makefile.am
+===================================================================
+--- git.orig/tests/Makefile.am 2013-05-08 15:18:56.918596425 +0100
++++ git/tests/Makefile.am 2013-05-08 15:23:26.864781401 +0100
+@@ -10,7 +10,8 @@
+
+ INCLUDES = \
+ -I$(top_srcdir) \
+- -I$(top_builddir)
++ -I$(top_builddir)\
++ -I$(top_builddir)/mx
+
+ noinst_PROGRAMS = \
+ test-deform-texture \