summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@kernel.crashing.org>2020-03-25 21:15:58 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-30 12:33:24 +0100
commitcd6bab044288779a67b94353ff91935f59bfcb56 (patch)
treec8488b33a3d2e96184d1f4cd0713a6581b8cac0b /meta/recipes-graphics/mesa
parent91f464177ed7ed59a4405a39a366b387338ae923 (diff)
downloadopenembedded-core-contrib-cd6bab044288779a67b94353ff91935f59bfcb56.tar.gz
mesa-gl: Allow mesa-gl to build without X11 enabled.
Trying to build mesa-gl without X11 enabled, results in numerous errors about being incorrectly configured, such as: ERROR: Problem encountered: building dri drivers require at least one windowing system or classic osmesa A rendering engine must be available, so per the error we enable osmesa if X11 is not available. Once 'osmesa' is enabled we also need to make sure that swrast for DRI is also available. Signed-off-by: Mark Hatle <mark.hatle@kernel.crashing.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa')
-rw-r--r--meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb b/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
index d4b1c1c454..c7897cdaf3 100644
--- a/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-gl_20.0.2.bb
@@ -6,5 +6,10 @@ PROVIDES = "virtual/libgl virtual/mesa"
S = "${WORKDIR}/mesa-${PV}"
-PACKAGECONFIG ??= "opengl dri ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
-PACKAGECONFIG_class-target = "opengl dri ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
+# At least one DRI rendering engine is required to build mesa.
+# When no X11 is available, use osmesa for the rendering engine.
+PACKAGECONFIG ??= "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa', d)}"
+PACKAGECONFIG_class-target = "opengl dri ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'osmesa', d)}"
+
+# When NOT using X11, we need to make sure we have swrast available.
+DRIDRIVERS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', ',swrast', d)}"