aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa_18.1.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-06-18 16:14:47 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-21 00:16:49 +0100
commit0cfc7488d67346bdc3975767366220e65f8de7d7 (patch)
tree9533dd4644a7e0187a01cd9e5157349a37bb8cb3 /meta/recipes-graphics/mesa/mesa_18.1.2.bb
parent6be8744d1b8ee35eb47acd517cfa29b2a7f455d5 (diff)
downloadopenembedded-core-contrib-0cfc7488d67346bdc3975767366220e65f8de7d7.tar.gz
mesa: Update 18.1.1 -> 18.1.2
This includes bug fixes for 18.1.x series. For list of changes check: https://www.mesa3d.org/relnotes/18.1.2.html Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa_18.1.2.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.1.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_18.1.2.bb b/meta/recipes-graphics/mesa/mesa_18.1.2.bb
new file mode 100644
index 0000000000..2c06b1eb7b
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa_18.1.2.bb
@@ -0,0 +1,22 @@
+require ${BPN}.inc
+
+SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
+ file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
+ file://0002-Simplify-wayland-scanner-lookup.patch \
+ file://0003-winsys-svga-drm-Include-sys-types.h.patch \
+ file://0004-hardware-gloat.patch \
+ file://0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
+ file://0006-Use-Python-3-to-execute-the-scripts.patch \
+ file://0007-dri-i965-Add-missing-time.h-include.patch \
+"
+
+SRC_URI[md5sum] = "a2d4f031eb6bd6111d44d84004476918"
+SRC_URI[sha256sum] = "070bf0648ba5b242d7303ceed32aed80842f4c0ba16e5acc1a650a46eadfb1f9"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ fi
+}