aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-06-06 10:45:48 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 10:59:33 +0100
commit8803a6e31a4b64eb9d3c146567375c98972074df (patch)
treec38ebb221d954342035b449a93fd254f6d9d272c /meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
parent322e41de7f4fb21315bf75f1038314c31ac4754b (diff)
downloadopenembedded-core-contrib-8803a6e31a4b64eb9d3c146567375c98972074df.tar.gz
mesa: Update 18.0.2 -> 18.1.1
This includes all bugfixes of 18.0.x series and major new features. For list of changes check: https://www.mesa3d.org/relnotes/18.1.0.html https://www.mesa3d.org/relnotes/18.1.1.html Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch')
-rw-r--r--meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch b/meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
new file mode 100644
index 0000000000..94189ac714
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0005-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch
@@ -0,0 +1,44 @@
+From 33025fb1650768a0b923f3c824c270628eef83db Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Tue, 5 Jun 2018 11:11:10 -0300
+Subject: [PATCH 5/7] Properly get LLVM version when using LLVM Git releases
+Organization: O.S. Systems Software LTDA.
+
+$ llvm-config-host --version
+5.0.0git-9a5c333388c
+
+We need to ignore everything after 5.0.0 which is what the cut cmd is
+doing
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7c95598afc..c248248c6b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1075,7 +1075,7 @@ strip_unwanted_llvm_flags() {
+
+ llvm_set_environment_variables() {
+ if test "x$LLVM_CONFIG" != xno; then
+- LLVM_VERSION=`$LLVM_CONFIG --version | egrep -o '^[[0-9.]]+'`
++ LLVM_VERSION=`$LLVM_CONFIG --version | cut -c1-5`
+ LLVM_CPPFLAGS=`strip_unwanted_llvm_flags "$LLVM_CONFIG --cppflags"`
+ LLVM_INCLUDEDIR=`$LLVM_CONFIG --includedir`
+ LLVM_LIBDIR=`$LLVM_CONFIG --libdir`
+@@ -2776,7 +2776,7 @@ detect_old_buggy_llvm() {
+ dnl ourselves.
+ dnl (See https://llvm.org/bugs/show_bug.cgi?id=6823)
+ dnl We can't use $LLVM_VERSION because it has 'svn' stripped out,
+- LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version`
++ LLVM_SO_NAME=LLVM-`$LLVM_CONFIG --version | cut -c1-5`
+ AS_IF([test -f "$LLVM_LIBDIR/lib$LLVM_SO_NAME.$IMP_LIB_EXT"], [llvm_have_one_so=yes])
+
+ if test "x$llvm_have_one_so" = xyes; then
+--
+2.17.1
+