summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.4.1.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-05-23 14:45:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-31 15:36:20 +0100
commite1afa8762c126eb963f4cf506404a734571c8389 (patch)
tree602b03bf7da5a3e683e9c0a96152a46dfbaf48ad /meta/recipes-graphics/libva/libva_2.4.1.bb
parentf3c995ee4be8de52e07d9d1320c5ea3b06d9141f (diff)
downloadopenembedded-core-contrib-e1afa8762c126eb963f4cf506404a734571c8389.tar.gz
libva: upgrade 2.4.0 -> 2.4.1
Changes in this release: 979a351 [common] Add A2RGB10 fourcc definition 22cba79 build: meson: enables va messaging and visibility b89f6ec va/va_trace: add trace support for RIR(rolling intra refresh). 844b90c va/va_trace: add trace support for ROI(region of interest). (From OE-Core rev: 6072f1f3a0064bbb550367386d96c6cf7d88e32c) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.4.1.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.4.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.4.1.bb b/meta/recipes-graphics/libva/libva_2.4.1.bb
new file mode 100644
index 0000000000..525721f0ae
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.4.1.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Video Acceleration (VA) API for Linux"
+DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
+and API specification which enables and provides access to graphics \
+hardware (GPU) acceleration for video processing on Linux and UNIX \
+based operating systems. Accelerated processing includes video \
+decoding, video encoding, subpicture blending and rendering. The \
+specification was originally designed by Intel for its GMA (Graphics \
+Media Accelerator) series of GPU hardware, the API is however not \
+limited to GPUs or Intel specific hardware, as other hardware and \
+manufacturers can also freely use this API for hardware accelerated \
+video decoding."
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/intel/libva/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "5b5ace9de3f07cb7b8f4d19b6979adf0"
+SRC_URI[sha256sum] = "e9e053908591b121793eaa5d8aa37675b4cd3af4b12f1f377dff4767f39cee70"
+
+UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
+
+DEPENDS = "libdrm virtual/mesa"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
+
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"