aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.3.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-11-16 18:13:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-16 13:53:55 +0000
commit8825a6e7c5c0d1e1d17e2bb8ed23dc8b3c9ce8ab (patch)
tree146db2527742e3edc0fbf0a397d0abb8aed56bc1 /meta/recipes-graphics/libva/libva_2.3.0.bb
parent62fe04c2451f612b9ee5eba469c7724b63484499 (diff)
downloadopenembedded-core-contrib-8825a6e7c5c0d1e1d17e2bb8ed23dc8b3c9ce8ab.tar.gz
libva: update 2.2.0 -> 2.3.0
>From release notes: Bump VA-API version to 1.3.0 and libva to 2.3.0 Add max frame size parameters for multiple pass case in legacy mode Add new BRC mode AVBR Add new interface for High Dynamic Range tone mapping Add missing enum to string conversions Add hevc subsets parameters structure Add Customized Noise Reduction (HVS) interfaces Add new BRC mode definition QVBR Add more complete colour properties for use in VPP Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.3.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.3.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.3.0.bb b/meta/recipes-graphics/libva/libva_2.3.0.bb
new file mode 100644
index 0000000000..4aab5269aa
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.3.0.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Video Acceleration (VA) API for Linux"
+DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
+and API specification which enables and provides access to graphics \
+hardware (GPU) acceleration for video processing on Linux and UNIX \
+based operating systems. Accelerated processing includes video \
+decoding, video encoding, subpicture blending and rendering. The \
+specification was originally designed by Intel for its GMA (Graphics \
+Media Accelerator) series of GPU hardware, the API is however not \
+limited to GPUs or Intel specific hardware, as other hardware and \
+manufacturers can also freely use this API for hardware accelerated \
+video decoding."
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/intel/libva/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "2555c46075ab2f6128f39902ba1c6183"
+SRC_URI[sha256sum] = "60840e50da6932ee2111e15fc8911180ff8a0d6f18bb9cc6ba8c1030098fdce4"
+
+UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
+
+DEPENDS = "libdrm virtual/mesa"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
+
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"