summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.2.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-07-13 10:39:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-18 10:09:29 +0100
commitd61d417750d4eadf5a00760e9859cb4c3b233cdc (patch)
tree2fe0e9695eefa9c62ccc85f03a4038c4d8c701a2 /meta/recipes-graphics/libva/libva_2.2.0.bb
parentd19a9b41d3b2dcba3b102a8289b7787b4b131e96 (diff)
downloadopenembedded-core-contrib-d61d417750d4eadf5a00760e9859cb4c3b233cdc.tar.gz
libva: upgrade 2.1.0 -> 2.2.0
* Bump VA-API version to 1.2.0 * Add support for hevc range extension decoding * Add support for fast intra prediction in HEVC FEI * Add 10/12-bit YUV render target formats * Add fourcc code for Y210/Y216/Y410/Y416/RGB565/BGR565 * Add VA_STATUS_ERROR_NOT_ENOUGH_BUFFER * Add VA_SURFACE_ATTRIB_USAGE_HINT_EXPORT * Improve documentation Tested with Intel vaapi driver. There is support for meson available but its not being packaged as part of release tarball yet. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.2.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.2.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.2.0.bb b/meta/recipes-graphics/libva/libva_2.2.0.bb
new file mode 100644
index 0000000000..11e57e0eb8
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.2.0.bb
@@ -0,0 +1,46 @@
+SUMMARY = "Video Acceleration (VA) API for Linux"
+DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
+and API specification which enables and provides access to graphics \
+hardware (GPU) acceleration for video processing on Linux and UNIX \
+based operating systems. Accelerated processing includes video \
+decoding, video encoding, subpicture blending and rendering. The \
+specification was originally designed by Intel for its GMA (Graphics \
+Media Accelerator) series of GPU hardware, the API is however not \
+limited to GPUs or Intel specific hardware, as other hardware and \
+manufacturers can also freely use this API for hardware accelerated \
+video decoding."
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/intel/libva/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "92d04ad1700136dc75b1e5f47516e704"
+SRC_URI[sha256sum] = "6f6ca04c785544d30d315ef130a6aeb9435b75f934d7fbe0e4e9ba6084ce4ef2"
+
+UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
+
+DEPENDS = "libdrm virtual/mesa"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
+
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"