aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_1.8.3.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2017-08-14 15:09:06 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 09:18:47 +0100
commitbcb77ab7f57a99284953a456399b90b6ed42e77d (patch)
tree1326d42b169b0cc5bf4a1c4822ee82562ec51a10 /meta/recipes-graphics/libva/libva_1.8.3.bb
parentab7f6ba2bab04bdfaa76a1de83806dbadc82fefa (diff)
downloadopenembedded-core-contrib-bcb77ab7f57a99284953a456399b90b6ed42e77d.tar.gz
libva: upgrade to 1.8.3
1.7.3 -> 1.8.3 Remove upstreamed patch: 0001-wayland-Don-t-commit-and-ship-generated-files.patch Replace following patch by setting ac_cv_prog in EXTRA_OECONF: 0001-configure.ac-Use-wayland-scanner-in-PATH.patch The dummy driver was removed in 1.8.3 release. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_1.8.3.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_1.8.3.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_1.8.3.bb b/meta/recipes-graphics/libva/libva_1.8.3.bb
new file mode 100644
index 0000000000..bb5f829fcc
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_1.8.3.bb
@@ -0,0 +1,51 @@
+SUMMARY = "Video Acceleration (VA) API for Linux"
+DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
+and API specification which enables and provides access to graphics \
+hardware (GPU) acceleration for video processing on Linux and UNIX \
+based operating systems. Accelerated processing includes video \
+decoding, video encoding, subpicture blending and rendering. The \
+specification was originally designed by Intel for its GMA (Graphics \
+Media Accelerator) series of GPU hardware, the API is however not \
+limited to GPUs or Intel specific hardware, as other hardware and \
+manufacturers can also freely use this API for hardware accelerated \
+video decoding."
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/01org/libva/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
+
+SRC_URI = "git://github.com/01org/libva.git;protocol=http;branch=v1.8-branch "
+SRCREV = "457470987cc9df5976ce8c72ffd4bfbd9baaf0f9"
+UPSTREAM_CHECK_GITTAGREGEX = "libva-(?P<pver>(\d+(\.\d+)+))"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libdrm virtual/mesa virtual/libgles1 virtual/libgles2 virtual/egl"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
+
+PACKAGES =+ "${PN}-x11 ${PN}-tpi ${PN}-glx ${PN}-egl ${PN}-wayland"
+
+RDEPENDS_${PN}-tpi =+ "${PN}"
+RDEPENDS_${PN}-x11 =+ "${PN}"
+RDEPENDS_${PN}-glx =+ "${PN}-x11"
+RDEPENDS_${PN}-egl =+ "${PN}-x11"
+
+FILES_${PN}-dbg += "${libdir}/dri/.debug"
+
+FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
+FILES_${PN}-tpi =+ "${libdir}/libva-tpi*${SOLIBS}"
+FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
+FILES_${PN}-egl =+ "${libdir}/libva-egl*${SOLIBS}"
+FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"