aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva-utils_2.1.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-21 12:30:16 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commita289787a80099d5029daab84625453cd3e2471b1 (patch)
treeecd55d05c89005e3cd0442c840357aedd35a254e /meta/recipes-graphics/libva/libva-utils_2.1.0.bb
parentf8c01917594892be366580873618fa20272d2423 (diff)
downloadopenembedded-core-contrib-a289787a80099d5029daab84625453cd3e2471b1.tar.gz
libva-utils: upgrade to 2.1.0
Major changes: * Refine gtest conformance cases * vp9enc: add support low power mode * vavpp: add support for RGBA/RGBX surface * vainfo: add support new profile/entrypoint pairs Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libva/libva-utils_2.1.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva-utils_2.1.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva-utils_2.1.0.bb b/meta/recipes-graphics/libva/libva-utils_2.1.0.bb
new file mode 100644
index 0000000000..a8018ea728
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva-utils_2.1.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "libva-utils is a collection of utilities from libva project"
+
+DESCRIPTION = "libva-utils is a collection of utilities \
+and examples to exercise VA-API in accordance with the libva \
+project.VA-API is an open-source library and API specification, \
+which provides access to graphics hardware acceleration capabilities \
+for video processing. It consists of a main library and driver-specific \
+acceleration backends for each supported hardware vendor"
+
+HOMEPAGE = "https://01.org/linuxmedia/vaapi"
+BUGTRACKER = "https://github.com/intel/libva-utils/issues"
+
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
+
+SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
+SRC_URI[md5sum] = "6649be70390606651cb636320bfd43c6"
+SRC_URI[sha256sum] = "f6a7790c3dcc56537372c90a83036a3136194a8b397e84e97bf9cc9254fa2c51"
+
+UPSTREAM_CHECK_URI = "https://github.com/intel/libva-utils/releases"
+
+DEPENDS = "libva"
+
+inherit autotools pkgconfig distro_features_check
+
+# depends on libva which requires opengl
+REQUIRED_DISTRO_FEATURES = "opengl"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
+PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
+PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"