aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-03-14 17:03:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-14 13:12:43 +0000
commit94e18a1c574b97ba87724c0fea79d2af77ba4186 (patch)
tree95b1369daf93a6325fb2b4f8e22f1a06624f7367 /meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
parente28f5ca21f07040e1c62ccd65c94e2df734770e4 (diff)
downloadopenembedded-core-contrib-94e18a1c574b97ba87724c0fea79d2af77ba4186.tar.gz
libsdl: update to 1.2.15
Update libsdl to 1.2.15. Patch add.XGetRequest.symbol.patch is merged by upstream, so remove it. Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libsdl/libsdl_1.2.15.bb')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
new file mode 100644
index 0000000000..8b394428dc
--- /dev/null
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -0,0 +1,65 @@
+SUMMARY = "Simple DirectMedia Layer"
+DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \
+library designed to provide low level access to audio, keyboard, mouse, \
+joystick, 3D hardware via OpenGL, and 2D video framebuffer."
+HOMEPAGE = "http://www.libsdl.org"
+BUGTRACKER = "http://bugzilla.libsdl.org/"
+
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
+
+PROVIDES = "virtual/libsdl"
+
+DEPENDS = "${@base_contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \
+ tslib"
+DEPENDS_virtclass-nativesdk = "${@base_contains('DISTRO_FEATURES', 'x11', 'libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk', '', d)}"
+
+PR = "r0"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+ file://configure_tweak.patch \
+ "
+
+S = "${WORKDIR}/SDL-${PV}"
+
+SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
+SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00"
+
+inherit autotools lib_package binconfig pkgconfig
+
+EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --disable-oss --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --disable-video-dga \
+ --disable-video-fbcon --disable-video-ps2gs --disable-video-ps3 \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --enable-input-events --enable-input-tslib --enable-pthreads \
+ ${@base_contains('DISTRO_FEATURES', 'directfb', '--enable-video-directfb', '--disable-video-directfb', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'x11', '--enable-video-x11', '--disable-video-x11', d)} \
+ --disable-video-svga \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen \
+ --disable-rpath \
+ --disable-pulseaudio"
+
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
+PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib,"
+
+PARALLEL_MAKE = ""
+
+EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
+
+do_configure_prepend() {
+ # Remove old libtool macros.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm -f acinclude/$i
+ done
+ export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
+}
+
+BBCLASSEXTEND = "nativesdk"