aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-01 22:20:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 17:08:32 +0000
commit80cee6088fa60eb5197f8ed9d135986b8e7d471a (patch)
tree9eb1857848204bd7f9a04dcb674e29a91d95a784 /meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch
parentb72154eccfbcc178a2c09c7c7d4cd0264d4cf0f6 (diff)
downloadopenembedded-core-contrib-80cee6088fa60eb5197f8ed9d135986b8e7d471a.tar.gz
libepoxy: improve musl patch
dlvsym() is used by the libepoxy test suite, but this is glibc-specific and isn't present in musl. Instead of adding an option to control whether dlvsym is available (which could be detected by Meson), as we don't install the test suite simply add an option to disable the entire test suite (and submit the patch upstream). Also remove the build dependency on util-macros as that is a remnant of the autotools build. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch')
-rw-r--r--meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch b/meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch
new file mode 100644
index 0000000000..d2b6c1a254
--- /dev/null
+++ b/meta/recipes-graphics/libepoxy/libepoxy/no-tests.patch
@@ -0,0 +1,33 @@
+Add option to disable tests.
+
+Upstream-Status: Submitted (https://github.com/anholt/libepoxy/pull/158)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/meson.build b/meson.build
+index b2ebaef..9632c7a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -242,7 +242,10 @@ libepoxy_inc = [
+
+ subdir('include/epoxy')
+ subdir('src')
+-subdir('test')
++
++if get_option('tests')
++ subdir('test')
++endif
+
+ if get_option('docs')
+ doxygen = find_program('doxygen', required: false)
+diff --git a/meson_options.txt b/meson_options.txt
+index b5d7c98..dc30e68 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -15,3 +15,7 @@ option('x11',
+ type: 'boolean',
+ value: true,
+ description: 'Enable X11 support (GLX or EGL-X11)')
++option('tests',
++ type: 'boolean',
++ value: true,
++ description: 'Build the test suite')