aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-02-23 10:54:24 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:36 +0000
commit6dc27726c9da5104ea27ebf604cab6ef2037034d (patch)
tree0cb11bd09cb4499c2f12dd85535ed24e47bbd9da /meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb
parent8cc47e6bfb7f623711d9cd9e71a7f72ab2838f57 (diff)
downloadopenembedded-core-contrib-6dc27726c9da5104ea27ebf604cab6ef2037034d.tar.gz
harfbuzz: update 1.2.0 -> 1.2.1
Overview of changes leading to 1.2.1 Friday, February 23, 2016 ==================================== - CoreText: Fix bug with wrong scale if font scale was changed later. https://github.com/libass/libass/issues/212 - CoreText: Drastically speed up font initialization. - CoreText: Fix tiny leak. - Group ZWJ/ZWNJ with previous syllable under cluster-level=0. https://github.com/behdad/harfbuzz/issues/217 - Add test/shaping/README.md about how to add tests to the suite. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb
new file mode 100644
index 0000000000..f88e634080
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_1.2.1.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Text shaping library"
+DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e021dd6dda6ff1e6b1044002fc662b9b \
+ file://src/hb-ucdn/COPYING;md5=994ba0f1295f15b4bda4999a5bbeddef \
+"
+
+DEPENDS = "glib-2.0 cairo freetype"
+
+SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "c50034739e4b5ea85d46199bf7859ea6"
+SRC_URI[sha256sum] = "0c189aa386c5ea8d7c315adf273f56f48f412081a367b3f92abc2d0855fa2226"
+
+inherit autotools pkgconfig lib_package
+
+PACKAGECONFIG ??= "icu"
+PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu"
+
+EXTRA_OECONF = "--with-glib --with-freetype --with-cairo --without-graphite2"
+
+PACKAGES =+ "${PN}-icu ${PN}-icu-dev"
+
+FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
+FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
+ ${libdir}/libharfbuzz-icu.so \
+ ${libdir}/pkgconfig/harfbuzz-icu.pc \
+"
+
+BBCLASSEXTEND = "native"