aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glew/glew_1.12.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-16 20:56:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-18 07:39:30 +0000
commitaea0746cbb7b9d286d12007bd7d2a346f27cfc62 (patch)
treedd79e69f7e95c85c162b8d0eb76af4c69c81175d /meta/recipes-graphics/glew/glew_1.12.0.bb
parent0b1c3240ad1c1880740e68312b28f5e83915bd44 (diff)
downloadopenembedded-core-contrib-aea0746cbb7b9d286d12007bd7d2a346f27cfc62.tar.gz
glew: rewrite to use upstream build system
Instead of patching in a whole new build system using autotools, use the makefile-based system in upstream with careful variable assignments so that it cross-compiles correctly. One small patch was required to stop an unavoidable strip. Upstream does have a cmake-based build but it's not used or supported by the maintainer, and is quite buggy (for example: doesn't version the libraries, fails to link to required libraries). (From OE-Core rev: c77d0dfa18b2467f8856571837e7007f8fcd9b20) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glew/glew_1.12.0.bb')
-rw-r--r--meta/recipes-graphics/glew/glew_1.12.0.bb28
1 files changed, 21 insertions, 7 deletions
diff --git a/meta/recipes-graphics/glew/glew_1.12.0.bb b/meta/recipes-graphics/glew/glew_1.12.0.bb
index ef416ec257..f1707d6655 100644
--- a/meta/recipes-graphics/glew/glew_1.12.0.bb
+++ b/meta/recipes-graphics/glew/glew_1.12.0.bb
@@ -8,12 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ac251558de685c6b9478d89be3149c2"
DEPENDS = "virtual/libx11 virtual/libgl libglu libxext libxi libxmu"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
- file://autotools.patch \
- file://glew_fix_for_automake-1.12.patch \
- file://fix-glew.pc-install.patch \
- "
+ file://no-strip.patch"
SRC_URI[md5sum] = "01246c7ecd135d99be031aa63f86dca1"
SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f48e4bf"
@@ -21,6 +17,24 @@ SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f
UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/glew/files/glew"
UPSTREAM_CHECK_REGEX = "/glew/(?P<pver>(\d+[\.\-_]*)+)/"
-inherit autotools lib_package pkgconfig distro_features_check
-# depends on virtual/libx11
+inherit lib_package pkgconfig distro_features_check
+
REQUIRED_DISTRO_FEATURES = "x11"
+
+# Override SYSTEM to avoid calling config.guess, we're cross-compiling. Pass
+# our CFLAGS via POPT as that's the optimisation variable and safely
+# overwritten.
+EXTRA_OEMAKE = "SYSTEM='linux' \
+ CC='${CC}' LD='${CC}' STRIP='' \
+ LDFLAGS.EXTRA='${LDFLAGS}' \
+ POPT='${CFLAGS}' \
+ GLEW_PREFIX='${prefix}' BINDIR='${bindir}' \
+ LIBDIR='${libdir}' INCDIR='${includedir}/GL'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install.all
+}