summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/drm
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-09 20:56:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:27:01 -0700
commit48614ce3ce13a8efa49bb323ef0646c4bb1c32c2 (patch)
tree45d196502beb68a952a5cbe9b85001bf400761e0 /meta/recipes-graphics/drm
parentc47e5edb67689310c3d49f4e2e20dbeaab7689a8 (diff)
downloadopenembedded-core-contrib-48614ce3ce13a8efa49bb323ef0646c4bb1c32c2.tar.gz
drm: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. (From OE-Core rev: 625be3dd6e3069333a3c94ca8f23129b23e4425b) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/drm')
-rw-r--r--meta/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/meta/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch b/meta/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
index bf526370b0..40bebc0f50 100644
--- a/meta/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
+++ b/meta/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
@@ -12,11 +12,11 @@ Upstream-Status: Submitted [mailing list]
configure.ac | 14 ++++++++++++--
1 file changed, 12 insertions(+), 2 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index e3048c7..918d21d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -137,6 +137,12 @@ AC_ARG_ENABLE(install-test-programs,
+Index: libdrm-2.4.91/configure.ac
+===================================================================
+--- libdrm-2.4.91.orig/configure.ac
++++ libdrm-2.4.91/configure.ac
+@@ -163,6 +163,12 @@ AC_ARG_ENABLE(install-test-programs,
[Install test programs (default: no)]),
[INSTALL_TESTS=$enableval], [INSTALL_TESTS=no])
@@ -29,8 +29,8 @@ index e3048c7..918d21d 100644
dnl ===========================================================================
dnl check compiler flags
AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
-@@ -372,7 +378,7 @@ if test "x$RADEON" = xyes; then
- AC_DEFINE(HAVE_RADEON, 1, [Have radeon support])
+@@ -411,7 +417,7 @@ else
+ AC_DEFINE(HAVE_RADEON, 0)
fi
-if test "x$AMDGPU" != xno; then
@@ -38,8 +38,8 @@ index e3048c7..918d21d 100644
# Detect cunit library
PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
# If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
-@@ -399,7 +406,11 @@ if test "x$AMDGPU" = xyes; then
- AC_DEFINE(HAVE_CUNIT, [test "x$have_cunit" != "xno"], [Enable CUNIT Have amdgpu support])
+@@ -436,7 +442,11 @@ if test "x$AMDGPU" = xyes; then
+ AC_DEFINE(HAVE_AMDGPU, 1, [Have amdgpu support])
if test "x$have_cunit" = "xno"; then
- AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
@@ -49,8 +49,5 @@ index e3048c7..918d21d 100644
+ AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
+ fi
fi
- fi
-
---
-2.1.4
-
+ else
+ AC_DEFINE(HAVE_AMDGPU, 0)